Требуется обновление PHP. Обновите PHP сегодня! Сделайте свой сайт быстрее и безопаснее.

  Автор:
  329
Требуется обновление PHP. Обновите PHP сегодня! Сделайте свой сайт быстрее и безопаснее.

Если увидите в консоли блога на WordPress вот такую надпись «Требуется обновление PHP. WordPress обнаружил, что вы используете небезопасную версию PHP.» значить пришло время обновить PHP до ее соременной версии.

У Вас скорее всего версия PHP 5.6 или ниже.

PHP — язык программирования, на основе которого создан WordPress. Версия PHP устанавливается на хостинге. На сегодняшний день последняя верия PHP 7.3.

После обновления Ваш сайт на WordPress будет работать бестрее и взломать его будет намного труднее.

Как обновить PHP

Чтобы выполнить директиву WordPress и обновить PHP заходим на хостинг.

Я покажу как обновить PHP на примере хостинга Timeweb.

  1. В панели управления аккаунта вашего хостинга нажимаем на кнопку раздела «Сайты», далее на иконку с зеленой шестеренкой, напротив домена вашего блога на WordPress.
  2.  Во всплывшим окне, в выпадающем меню, выберите PHP 7.2 или выше. Для сохранения настройки нажмите на кнопку «Сохранить настройки».

Таким образом, Ваш блог на WordPress будет переведен на современный PHP, и  директива WordPress в консоли блога исчезнет.

Очень важное примечание! Если у Вас установлены старые плагины или шаблон, то перед обновление PHP сделайте резервную копию блога.  Затем обновите PHP на хостинге и проверьте все ли впорядке с блогом. Возможно устаревшие плагины, которые не обновлялись несколько лет, работать не будут. В этом случае им нужно найти альтернативную замену.

Шаблон — конструктор AB-Inspiration и его премиум плагины постоянно обновляются и работают на новых версиях WordPress и PHP.

Как проверить работоспособность установленого плагина

Чтобы проверить совместим ли Ваш установленый плагин со свежей версией PHP 7 и выше, будет ли он работать после обновления PHP нужно сделать следующее.

Рассмотрим на примере плагина Akismet Anti-Spam (кстати, этот плагин с недавних пор для коммерческих сайтов стал платным).

1. В разделе «Установленые плагины» выбираем плагин и нажимаем кнопку «Детали».

 

2. На отрывшейся странице справа смотрим надпись — Совместим вплоть до: 5.2.2 ( на данный момент) или выше.  Если такая надпись есть значит все в порядке. Ваш плагин гарантированно совместим сновой версией PHP, которую Вы установите на хостинге.

 

Что делать если плагин несовместим с новой версий PHP

Как вариант, установите снова прежнюю версию PHP, сделайте бекап блога. WordPress работает даже со старой версией PHP 5.6.  Если версия PHP меньше 5.6, и блог на этой версии не будет работать, то все же нужно сделать обновление PHP до  версии 7 и выше и заменить плагины на альтернативные.

Если вы сомневаетесь в своих силах, мы принимаем заказы по обновлению версии PHP и устранению неполадок связанных с обновлением.

За помощью обращайтесь в нашу службу поддержки. Кнопка службы поддержки вверху блога справа. Мы всегда рады Вам помочь.

Требуется обновление PHP. Обновите PHP сегодня! Сделайте свой сайт быстрее и безопаснее.

   1 голос
Средняя оценка: 5 из 5
Вы находите данную статью полезной или интересной? Поделитесь ею, пожалуйста, с другими - просто нажмите на кнопки ниже:

Анфиса Бреус

Анфиса Бреус - разработчик сайтов на Wordpress с 2007 года. Создатель и разработчик универсального шаблона - конструктора "AB-Inspiration" для самостоятельного создания и профессиональной настройки сайтов на WordPress. Основатель клуба "Мастер WordPress". Спикер. Путешественница.

Пошаговый план по созданию бизнес-блога на WordPress
Оставьте свой комментарий:

на Блоге
в Фейсбук
в Вконтакте